Requirements

If you want to use InvoicePlane you have to follow these requirements to use the application.

  • A webserver / shared hosting with the following specifications:
    • MySQL > 5.5 or the equivalent version of MariaDB
    • PHP > 5.6, using PHP 7.0 or 7.1 is recommended
    • The following PHP extensions must be installed and activated:
      • php-gd
      • php-hash
      • php-json
      • php-mbstring
      • php-mcrypt
      • php-mysqli
      • php-openssl
      • php-recode
      • php-xmlrpc
      • php-zlib
  • An up-to-date web browser. We do recommend using either Google Chrome, Firefox or the latest version of Safari. Internet Explorer is only supported from version 11.
Please be aware that many users reported issues with the following hosting providers:
Go Daddy shared hosting
Please notice that PHP 5.5 is no longer supported and should not be used anymore for producton environments!
Installation